Burning

Mini and Small Systems

"Error: Opening COMxx: Access denied" Is Displayed After a Serial Port Is Selected for Burning

  • Symptom

    Error: Opening COMxx: Access denied is displayed after clicking Burn and selecting a serial port.

  • Possible Causes

    The serial port has been used.

  • Solution

    The serial port may be in use. Perform the following steps to troubleshoot:

    1. Search for the serial port from the drop-down list in the TERMINAL panel.

    2. Click the dustbin for the terminal using the serial port to disable the terminal.

What should I do when the image failed to be burnt?

  • Symptom

    The burning status is not displayed after clicking Burn and selecting a serial port.

  • Possible Causes

    The IDE is not restarted after the DevEco plug-in is installed.

  • Solutions

    Restart the IDE.

What should I do when no command output is displayed?

  • Symptom

    The serial port shows that the connection has been established. After the board is restarted, nothing is displayed when you press Enter.

  • Possible Cause 1

    The serial port is connected incorrectly.

  • Solutions

    Change the serial port number.

    Start Device Manager to check whether the serial port connected to the board is the same as that connected to the terminal device. If the serial ports are different, perform step 1 in the Running an Image section to change the serial port number.

  • Possible Cause 2

    The U-Boot of the board is damaged.

  • Solutions

    Burn the U-Boot.

    If the fault persists after you perform the preceding operations, the U-Boot of the board may be damaged. You can burn the U-Boot by performing the following steps:

  1. Obtain the U-Boot file.

    NOTICE: The U-Boot file of the two boards can be obtained from the following paths, respectively. Hi3516D V300: device\hisilicon\hispark_taurus\sdk_liteos\uboot\out\boot\u-boot-hi3516dv300.bin Hi3518E V300: device\hisilicon\hispark_aries\sdk_liteos\uboot\out\boot\u-boot-hi3518ev300.bin

  2. Burn the U-Boot file by following the procedures for burning a U-Boot file over USB.

    Select the U-Boot files of corresponding development boards for burning by referring to Programming Flash Memory on the Hi3516/Programming Flash Memory on the Hi3518

  3. Log in to the serial port after the burning is complete.

    Figure 1 Serial port displayed after the U-Boot is burnt

What should I do when Windows-based PC failed to be connected to the board?

  • Symptom

    The file image cannot be obtained after clicking Burn and selecting a serial port.

    Figure 2 Failed to obtain the image file due to unavailable connection

  • Possible Causes

    The board is disconnected from the Windows-based PC.

    Windows Firewall does not allow Visual Studio Code to access the network.

  • Solutions

  1. Check whether the network cable is properly connected.

  2. Click Windows Firewall.

  3. Click Firewall & network protection, and on the displayed page, click Allow applications to communicate through Windows Firewall.

  4. Select the Visual Studio Code application.

  5. Select the Private and Public network access rights for the Visual Studio Code application.